US flag signifying that this is a United States Federal Government website An official website of the United States government

Updates

Nov 20, 2017

cloud.gov monthly update: Buildpack notifications, volume services, and other new features

We’ve been hard at work shipping out new features to help you make your apps better, more secure, and improve your experience developing and deploying them. There’s a lot more in here than usual. We hope you see some features and additions in here that you’ve been waiting for. As always, get in touch with us if you have any questions or feedback about these features. See you next month.

Added

Thanks to our antipodal compatriots with the Australian Government Digital Transformation Agency for this code contribution.

Screenshot of the environment variable editing view on the dashboard

Updates

Make sure to use the latest version of the Cloud Foundry CLI. The most recent updates contain new commands and bug fixes. You can download the latest binary for Windows, Mac, or Linux from GitHub.

Announcement

Coming soon

Sandbox apps will expire after 90 days

We plan to automatically delete apps in sandbox spaces after 90 days. We’ll send email notifications before this happens. If you’re developing something you need to keep long-term, we recommend moving it to a prototyping space. If you’d like to start the process of purchasing a prototyping package, get in touch with us.

Additional TIC compliance support

To support agency implementations of Trusted Internet Connection (TIC) requirements, we’ve published documentation about complying with TIC for apps on cloud.gov. To support a wider range of agency TIC needs, we’ve also built a way to support restricting users to trusted IP ranges. We’re waiting to fully implement it until after it’s passed FedRAMP review, but in the meantime, let us know if you have questions or want to use it.

Platform releases

We upgraded the Cloud Foundry deployment to v278.

You should restage your application to incorporate fixes in the base filesystem and ensure you’re running the most recent language version supported by your buildpack.

Additional upgrades